Viper’s Video Quicktags + WordPress 2.5

UPDATE #2: Try v5.4.3. I’ve heard multiple reports it’s working fine for those who tried it. Let me know.


UPDATE: I just committed version 5.4.2. Try this and see if it fixes any problems. I couldn’t reproduce any errors on demand, but I made some code improvements to hopefully fix the problem.


I updated Viper’s Video Quicktags before WordPress 2.5 came out and it was 100% compatible then. Infact, it still is fully compatible with WordPress as far as I can tell.

However! It doesn’t seem to be compatible with many other plugins out there, namely ones that use the “ButtonSnap” PHP class that allows for easy adding of buttons to the classic style editor and old versions of TinyMCE. I’m working on fixing it, but it’s hard to debug it.

Meanwhile, the following work around worked for me: click the “Deactivate All Plugins” button, activate my plugin FIRST, then activate all the other plugins.

Thanks for being patient while I sort this out.

40 thoughts on “Viper’s Video Quicktags + WordPress 2.5

  1. odd. thought F5 alone was a refresh. CTRL F5 fixed it. Wow, all day and all I needed to do was press an extra key when refreshing…….*sigh*

  2. Now if someone could only get Flexible Upload to work with 2.5, I’d be all set and able to upgrade my main blow. Anyway, Viper007Bond, thanks for keeping this up to date and working!

  3. Hi! The latest version (5.4.3) doen´t work with tinymce advanced plugin. The video quicktags can be dragged and dropped into the toolbars, but they didn´t appear in write panel. A browser refresh (f5 or ctrl+f5) also deleting the browsers cache does fix the problem.

  4. It´s me again 😉 I found another problem. In the options i activated the quicktime videos but the button isnt shown in the toolbar. Btw. i´m using WP 2.5, tinymce 3.0 an VVQT 5.4.3. If i deactivate the tinymce adv. plugin the quicktime button problem is still remaining.

  5. Viper007Bond on April 1st, 2008 at 6:08 PM wrote:

    [quote comment=”47033″]5.4.3 don’t show videos in my blog with WP 2.5 🙁 only show a link:

    http://scitec.nosdom.com/?p=2400

    The Javascript file isn’t loading (click, it shows permission denied). Check your permissions.[/quote]

    I Check the permissions. I put vipers-video-quicktags.js and vipers-video-quicktags.php with 777 and 755 permision on the directory and thats all OK.

    Thank you very much 😉 good work

  6. EDIT to my first comment… Of course i wanted to say that it does NOT fix the problem! I am sorry for this.

  7. Hm… I think you misunderstood me. Vipers Video Quicktag Plugin (your plugin) has a problem with default tinymce added in WP (in this case the tinymce advanced plugin is deactivated!). The Quicktime Button isn´t shown in the editor. Maybe i am the only one that´s having this issue…

    The second problem occures when the tinymce advanced plugin is activated. The version before works propably. I don´t think it´s a problem of tinymce advanced.

    Both errors came up after i updated to the latest version of your plugin.

  8. Michael on April 2nd, 2008 at 2:19 PM wrote:

    The Quicktime Button isn´t shown in the editor.

    Nor does the standard video file button. Both of these are hidden on purpose. This is because TinyMCE 3 has Quicktime and standard video file embedding built in. I don’t need to duplicate that feature by adding my own buttons. 😉

    Michael on April 2nd, 2008 at 2:19 PM wrote:

    The second problem occures when the tinymce advanced plugin is activated. The version before works propably. I don´t think it´s a problem of tinymce advanced.

    I think it is. My plugin follows the official TinyMCE 3 API and unless I made a mistake somewhere (please, let me know if I did), there’s nothing wrong with my plugin.

    I’d suggest you talk to the author of TinyMCE Advanced.

  9. Hi & thanks for your reply! Okay, but there´s still the option to activate the quicktime button. That´s a bit misleading. I think i´m not the only user who´s wondering why this option won´t work. But now it´s clear 😉

    I can´t tell you if you made a mistake since the last version. I simply wait for a new version of tinymce advanced. Perhaps then the problem will be fixed…

    Thank you for your patience so far! 😉

  10. Michael on April 2nd, 2008 at 11:45 PM wrote:

    Okay, but there´s still the option to activate the quicktime button. That´s a bit misleading. I think i´m not the only user who´s wondering why this option won´t work. But now it´s clear 😉

    It’s there because not everyone uses TinyMCE. Personally, I hate it and I have physically deleted the files from all of my non-dev blogs. Can’t stand the thing.

    Although I guess I could hide those rows if the user has TinyMCE selected. I’ll leave that for the next recode though.

    Michael on April 2nd, 2008 at 11:45 PM wrote:

    I can´t tell you if you made a mistake since the last version. I simply wait for a new version of tinymce advanced. Perhaps then the problem will be fixed…

    Literally nothing related to TinyMCE was changed between versions 5.4.0 and 5.4.3. So if it worked for you with 5.4.0 but not with 5.4.3, then something else not related to my plugin is causing your issues. 😉

  11. I have a question I hope you won’t mind answering. How can I code a blog entry to wrap text around a video provided by your plugin?

Comments are closed.